< HomePage | Снимки
<- Сряда, 30 Март 2005 | Начална страница | Петък, 1 Април 2005 ->
Четвъртък, 31 Март 2005
Как да повярваш в мрежови духове?

Преди няколко дни ми върнаха wireless устройството (D-LINK 7100AP), и тъй като беше пренастроено трябваше да го наглася, както на мен ми се иска.

Тези устройства се конфигурират през Web интерфейс, а за да ги конфигурираш трябва заявките към web сървъра да идват от адрес в мрежа 192.168.0.0/24. Та значи включвам устройството в домашният ми switch, ресетвам го като задържах копчето ресет 10 секунди, вдигнах си на мрежовата карта адрес от 192-ра мрежа (ifconfig eth0:1 192.168.0.1 netmask 255.255.255.0), но тъй като бях забравил, на кой точно адрес слуша устройството сканирах цялата мрежа за отворен порт 80 (nmap -sS -p 80 192.168.0.0/24). Изкочи ми web сървър на адрес 192.168.0.30. Дотук добре.

Стартирах Firefox, отворих http://192.168.0.30/ и първото, което ми направи впечатление е, че интерфейсът за настройка изглежда по съвсем различен начин от това, което помнех. Даже и картинката на устройството в интерфейса беше съвсем друга от самото устройство, което е стоеше мен. Изгледа че софтуера беше за DWL-800AP, което е съвсем различно от DWL-7100AP.

Позачудих се малко, но все пак започнах да настройвам. Стартирах wizard-а, нагласих криптиране, идентификация на устройството и тук следваше още една изненада, никъде нямаше да настроя аутентикация.

През това време си пуснах лаптопа и той веднага намери wireless устройство закачи се и даже имах достъп до мрежата. Естествено да осигурявам свободен достъп до домашната ми мрежа и до интернет връзката ми на всички в околноста изобщо не ми е минавало през ум. Затова и продължих да търся в интерфейса, настройките за аутентикация.

Прерових всичко и няма и няма. Само куцият WEP, а аз исках да ползвам WPA-PSK. Гледайки различният интерфейс от познатият на мен, ми дойде идеята, че някой умник е сменил фърмуера на устройството с грешният. Отидох на сайта на D-LINK и свалих последна версия на фърмъуера за устройство DWL-7000AP и се пробвах да го кача. Нищо не стана. С два браузера пробвам и на двата не ми дава да го кача, като във Firefox ми казва че сървъра не върнал нищо, а в konqueror се оплаква че сървъра върнал грешка 400 (bad request). Мама му стара, започнах да се изнервям, защото предположих че иска микрософтски браузер.

До тук вече около час се бях мъчил с тъпото устройство, лаптопа ту се закачаше, ту се разкачаше, десет пъти ресетвах устройството и ми стана интересно, че не си забравя паролата за достъп, която съм настроил. Накрая реших че трябва по някакъв начин да се обнови фърмуера и реших да го отнеса в офиса на по-големите спецове от мен да го нагласят.

Бързо превъртане до днес.

Бъзикали се в офиса с D-LINK-чето и му обновили фърмуера. Бил съм направил грешката, че съм се опитвал да качвам американски фърмуер на европейско устройство. Качили европейският без проблем. Та взимам си аз устройството и бягам към вкъщи за да го пусна, псувайки се на ум колко съм прост да не се сетя за разликите в американският и европейският фърмуер.

Включвам устройството, сканирам 192-ра мрежа и ми се появяват web сървъри на адреси 192.168.0.30 и 192.168.0.50. Ново пет...Отварям 192.168.0.30 и влизам със старото име и парола, което съм настроил и виждам старият интерфейс, който виждах и преди 2 дни. Изобщо не мога да разбера какво става, казаха ми че софтуера е обновен?!?!

Отварям 192.168.0.50, но до там нямам достъп въпреки че ползвам името admin и празна парола, както пише в документацията. Ресетвам устройството един, два, три пъти и пак същото. На 192.168.0.30 не си забравя паролата на 192.168.0.50 не ме пуска.

Звъннах по телефона и ме увериха, че софтуера на устройството е обновен и че няма парола и на адрес 192.168.0.50 трябва да мога да си го настроя.

Вече откачам и нищо не разбирам, ебаси и чудото. Започвам да си мисля дали в околността няма друг wireless и аз бъзикам него. Но как имам достъп през до него през моята вътрешна мрежа?

Я да пробвам да извадя кабела от моето устройство...Вадя го. Е сега ако всичко работи, значи....не знам.

Отварям 192.168.0.30 - РАБОТИ със старата парола!

Отварям 192.168.0.50 - РАБОТИ но не познавам паролата!

А стига бе, изби ме студена пот и за малко повярвах в духовете на мрежата, които при условие, че не ми е включено устройството, имам достъп не само до него ами и до някакво друго.

След първоначалното шашкане, реших да сваля адреса от мрежовата карта и да го вдигна пак. Бяха ми свършили всички идеи и реших да ползвам уиндолският начин, спри пусни, може пък да тръгне. Свалих мрежовата карта (ifconfig eth0:1 down), тръгнах да и вдигам пак адрес от 192-ра мрежа и тук ми светна лампата в главата! Защо по дяволите вдигам мрежа 192.168.0.0/24 на eth0, която ми е картата към кабелният модем, а не на eth2, която ми е картата към вътрешната мрежа?

Ааааааааааааааааааааа! Къде бил ключа за палатката. Аз изобщо не виждам моето устройство, а някакви други. Вдигнах адреса на eth2 и си видях устройството.

Какво всъщност се случи та да ме накара да повярвам в мрежови духове? Случи се комбинация от мои грешки и предположения.

Първо: вместо да вдигам мрежата на вътрешната карта eth2 (където е устройството) аз вдигнах мрежата на външната eth0 (където е интернета и мрежата на UnixSol към кабелните модеми).

Второ: въпреки че в документацията за DWL-7000AP пише че адреса за администрация е 192.168.0.50, първият път единственото устройство, което открих беше на адрес 192.168.0.30 и беше съвсем друго устройство. Това трябваше със сигурност да ми подскаже, че гледам не където трябва, но аз предположих че някои е сменил фърмуера на моето устройство. Логично нали?

По-късно разбрах че на 192.168.0.30 има устройство в една от нашите точки (който го пуснал без парола ще си понесе наказанието!).

Трето: Когато за втори път включих устройството не проверих мрежовите карти, просто видях че на 192.168.0.50 има устройство и се опитах да го администрирам. Ако си спомняте от прочетено по-горе, това устройство не ме допускаше въпреки всичките ресети, който правех на устройството при мен. В момента в който ми просветна се сетих, че това е другият DWL-7000AP, който е у колегата Спас. Това устройство преди два дни го нямаше в мрежата, затова при първият ми опит за настройка виждах само устройството на адрес 192.168.0.30.

Забелязвате ли как от една дребна грешка ifconfig eth0:1 ... вместо ifconfig eth2:1 ... ме накара да повярвам в духове?

[ Коментари: 7 | Добави коментар ]
Коментари

Така ти се пада, като трошиш на хората мрежите, троши си собствената да видиш как е ;)))) Пак добре че не си влезнал на комшията в Wirelessa ;)

Написа Габо (www) на 01-Apr-2005 15:53


Някъде около мен има един незащитен linksys и си го ползвам от време на време.

Написа Георги Чорбаджийски (www) на 01-Apr-2005 15:54


Хехе, много фън Жорка, мани ма и аз за малко да повярвам в духове покрай твойто преживяване, въпреки че бях убеден че е някой mixup :) Ма пак са бели кахъри. Пробвай да конфигурираш Cisco кабелен модем в routing mode. Не че не става, става но не работи... и така 18 пъти :)

Написа Колегата (www) на 07-Apr-2005 12:35


:)) Am dam... Jore ima duhove v tezi D-Link mnogo az sushto sam se overqval, osobeno v D-link 900 AP+ . Tuka v edno targovishko gradche izgradih wirelles mreja i otivam az da naglasqm AP-to saotvetniqt delink vlizam az v moqt chovek naglasqm si go i se varzvam prez laptopa s edno USB ustroistvo, taka do tuka sichko e ok raboti si ima si netec.NO sled kato toj reshil da go kachi na pokriva i go slojil zao4vat i problemite :) pone 3-puti sam hodil do tam i to za kakvo.Problema se okaza che e ot naprejenieto koeto toi podava kam ustrojstvoto.Po kabel okolo 25 metra pusnal 7.5 v i dokato signe do tam to namalqva,:) posle po kabel 15 metra sashtata rabota ave i az mu vikam ti da ne si lud ve q vkarai 220V napravo i ne se zanimavai.Eh mamamu stara tova dokato go razbera ot de ide hubavo che si bqh vzel edin multicet da go izmerq golqma muka :) che nebqha kachvaniq na pokriva che neznam si kakvo a to kakvo onq reshil da ikonomisa tokov kabel za smetka na UTP.

Написа sasbass (www) на 27-Jun-2006 15:45


Интересно - особено за хора като мен, с по няколко D-link устройства.
Не можах да разбера само, какво му е лошото да пуснеш отворена безжична мрежа? Естествено, не собствената си, а какъв да е нет, за зор-заман.

Написа Орлин Бориславов (www) на 22-Aug-2006 12:46


Лошото е когато някой през твоята "отворена" мрежа направи яка магария и при теб кацнат приятни хорица да обясняваш защо си направил еди какво си.

Написа Георги Чорбаджийски (www) на 22-Aug-2006 12:58


няма ли история за духове
ИСТИНСКА!

Написа криска на 16-Feb-2007 17:24


Добавяне на коментар
Не пишете nicknames, освен ако не се обръщам така към вас.
Е-мейл адресът няма да се показва на сайта.
Към него ще има връзка.

Коментарът трябва да е написан на български с кирилица или на английски. Останалите се трият.

Запомни адреса и името ми, за да не го пиша следващия път
начало
Valid XHTML 1.0! Valid CSS!